关注IT专业技能,持续提升竞争力。

IntelliJ IDEA14.1发布springmvc项目时JDK报错

JAVA 仙人球 2026℃ 0评论

在IntelliJ IDEA 14.1中使用在java项目中使用Maven时当没有在Maven中配置JDK编译版本、源码版本时,IDEA将默认的编译版本、源码版本设置为jdk5。

报错信息如下:

源值1.5已过时,将在未来所有版本中删除

目标值1.5已过时,将在未来所有版本中删除

如何处理?在项目的pom.xml文件中添加如下内容:

重新编译发布即可。

转载请注明:V-Lover » IntelliJ IDEA14.1发布springmvc项目时JDK报错

喜欢 (3)or分享 (0)
发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址